chaihongjun.me

【SASS】编译环境安装配置

  SASS是由Ruby所写,要使用SASS之前必须安装Ruby,本地环境是Win7+Sublime Text3,安装步骤如下:

  1. 从 http://rubyinstaller.org/  下载  RubyInstaller for Windows最新版本并安装。在安装的过程中注意勾选安装到系统的环境变量中,不然后面编译SASS文件的时候会出错。

    【SASS】编译环境安装配置

  2. 安装过程基本除了环境变量需要注意勾选,其他的基本都是一路next完成。

  3. 安装完Ruby之后,最好先更新下gem,也就是ruby的包管理工具

gem update --system

由于众所周知的原因,在更新gem的时候并不会那么的顺利,最好能够FQ出去顺畅的更新,如果你有代理可以这样:

set HTTP_PROXY=http://yourproxyip:yourproxyport
gem update --system

或者

gem update --system --http-proxy http://yourproxyip:yourproxyport

4.代理速度慢的话,更新时间会比较的久,需要耐心等待,gem更新完之后添加新的gem源,代替被墙的源

gem sources --add https://gems.ruby-china.org/ 
gem sources --add http://mirrors.aliyun.com/rubygems/
gem sources --remove https://rubygems.org/

以上只是Ruby安装,以及Ruby的包管理工具安装及更新,后面进入SASS安装:

gem install sass

OK SASS安装完毕!

一些命令:

gem update sass  #sass更新升级
sass -v #查看sass版本
sass -h #关于sass的帮助命令


知识共享许可协议本作品采用知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议进行许可。作者:柴宏俊»